Important Update: Security Certificate and Service Impact

Incident Report for Refyne Platform

Resolved

This incident has been resolved. Our team has resubmitted all submissions that were previously reported as queued. We will continue working tomorrow to resubmit anything outstanding. Please inform our support team if you notice any submissions from 4/27 to 4/29 that were not delivered or picked up.
Posted Apr 29, 2024 - 21:08 EDT

Monitoring

CMS has promised a resolution by the end of the day. We will update this page once the issue is resolved. Additionally, our team will take care of any submissions in a queued state or let you know if anything cannot be resubmitted. Thank you for your patience.
Posted Apr 29, 2024 - 15:58 EDT

Identified

We wish to inform you about an important matter concerning our security certificate. We have observed that the scheduled certificate updates are currently pending with CMS. This may lead to service degradation or interruptions in our usual operations.


We will continue to provide regular updates as we work through this process. We apologize for any inconvenience this may cause and appreciate your understanding and support as we ensure the continuity and security of our services.
Posted Apr 29, 2024 - 10:13 EDT
This incident affected: CMS and Refyne DM API.