Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 04, 2025 - 09:00 EST
Scheduled
esMD is performing system updates on Saturday, January 4th, 9:00-11:00 AM ET. While our services will remain accessible, there may be delays in submission delivery and status updates during this window. Normal operations will resume after maintenance is complete.
Please contact us if you have any questions.
Posted Jan 03, 2025 - 10:28 EST
This scheduled maintenance affected: CMS and Refyne DM API.